Milestone 1

Steps

Setup server

  • Added more ram

ESXi Setup

  1. Plugged into network (got ipmi network)
  2. Went to web gui (192.168.3.164 {DHCP})
    1. Logged in
      • Username: ADMIN
      • Password: redacted
    2. Used iKVM/HTML5
      • Launched from usb (physically plugged into server)

Started ESXi install

  1. Used the 500GB m.2 drive as main boot drive
  2. Set root password
  3. Installed OS to disk

Put Super in rack

  1. Configured networking for eth0
  2. IP: 192.168.7.32
  3. Sub: 255.255.255.0
  4. Gateway: 192.168.7.250

Connect to ESXi in web GUI

Upload ISOS

  • Upload isos
    1. Go to Storage
    2. Datstore browser
    3. make isos folder
    4. Upload

Make Virtual Switch

  • Go to the networking tab
    1. Virtual Switches
      1. Add standard virtual switch
      2. Name: 480-WAN
      3. And delete uplink1

Port Groups

  • Port Groups
    1. Add Port Group
    2. Name: 480-WAN
    3. Virtual Switch: 480-WAN

Making a New VM

  1. Virtual Machines

  2. Create / Register VM

  3. Name

  4. Fill out host information

  5. Allocate proper resources for box.

  6. For storage make sure to have Thin Provisioned.

Vyos Box

  1. Vyos (Install is pretty simple)
    1. Login (Default is vyos vyos)
    2. Type install `Install image` and follow prompt
    3. For password make it basic then when we make linked clones that’s when we set the complex password
    4. Reboot
  2. You must delete the interfaces as the mac address is baked into the config
configure
delete interfaces ethernet eth0 hw-id
delete interfaces ethernet eth1 hw-ed
commit
save

First command is to allow dhcp on boot and the second is to make sure ssh is listening anywhere

set interfaces ethernet eth0 address dhcp 
set service ssh listen-address 0.0.0.0 
  1. poweroff

Prepare VYOS for base VM

  1. Remove the CDrom
  2. Take a snapshot of 480-fw
    • Use `Base` for base vm snapshots
  3. Turn back on Vyos

VYOS Config for Milestone 1:

set interfaces ethernet eth0 description CYBERLAB
set interfaces ethernet eth1 description 480-WAN
delete interfaces ethernet eth0 address dhcp
set interfaces ethernet eth0 address 192.168.7.62/24
set interfaces ethernet eth1 address 10.0.17.2/24
set protocols static route 0.0.0.0/0 next-hop 192.168.7.250
set system name-server 192.168.4.4
set system name-server 192.168.4.5
set service dns forwarding listen-address 10.0.17.2
set service dns forwarding allow-from 10.0.17.0/24
set service dns forwarding system
set nat source rule 10 source address 10.0.17.0/24
set nat source rule 10 outbound-interface eth0
set nat source rule 10 translation address masquerade
set system host-name 480-fw

Ubuntu Box

  1. Make sure to have the xubuntu iso
  2. Install is very straight forward (any other debian based install)
  3. Have very default password
  4. Now run Devins script for setup
wget https://raw.githubusercontent.com/gmcyber/RangeControl/main/src/scripts/base-vms/ubuntu-desktop.sh
chmod +x ubuntu-desktop.sh
./ubuntu-desktop.sh
rm *.deb ubuntu-desktop.sh
showdown -h now
  1. Take snapshot of VM
    • Use `Base` for base vm snapshots
  2. Turn on vm and delete default user
sudo adduser paul
usermod -aG sudo paul
  1. Logout / Login paul
userdel -r champuser
  1. Now network xubuntu box

  2. Set hostname

sudo hostnamectl set-hostname xubuntu-wan
  1. All Done now proof time!

Proof